MPLS小实验:通过FEC标签接受控制策略配置LSP

发布时间:2021-11-29 13:56:31 作者:衡水铁头哥阅读:0

[导读]:与MPLS相关的协议主要是RFC3031(MPLS:多协议标签交换架构)和RFC3032(MPLS标签栈编码)。通过上个实验(MPLS小实验:利用LDP动态建立LSP),我们已经知道LDP(Label...

MPLS相关的协议主要是RFC3031(MPLS:多协议标签交换架构)和RFC3032(MPLS 标签栈编码)。

通过上个实验(MPLS小实验:利用LDP动态建立LSP),我们已经知道LDP(LabelDistributionProtocol、标签分发协议)可以用来动态建立LSP。使LDP后,LSR可以将网络层的IP路由信息映射到MPLS的标签交换路径上。通过在LSR上配置LSP触发策略,可以限制哪些引入LDP的路由表项可以触发LDP,为其目的分配网址标签,建立LSP。

LSP的作用类似于路由,手动配置类似于静态路由,LDP类似于动态路由;FEC的作用类似于等价路由,那么如何使用这个功能呢?

通过FEC标签接受控制策略配置LSP,今天进行实验。

组网需求

RT1-4均支持MPLS,在RT1到RT4之间通过LDP建立LSP,使11.1.1.0/24和44.1.1.0/24这两个网段中互访的报文能够通过MPLS进行传输。

RT1和RT4之间存在两条路径:RT1-RT2-RT4和RT1-RT3-RT4,通过配置标签接受控制策略,实现只沿着路径RT1-RT3-RT4建立LSP。

组网图

FEC标签接受控制策略配置LSP组网图。

MPLS小实验:通过FEC标签接受控制策略配置LSP

实验环境

Windows 10专业版(1909-18363.1556,16 GB内存)HCL 3.0.1

MSR 36-20(Version 7.1.064, Release 0821P11)配置步骤

首先按照组网图所示配置各接口的IP地址和掩码,并在RT1、RT2和RT3上配置OSPF,实现各路由器之间路由可达。配置开启每台设备和接口的的MPLS和LDP功能。各设备配置如下:

RT1

#sysname RT1

#ospf 1 router-id 1.1.1.1

area 0.0.0.0

network 1.1.1.1 0.0.0.0

network 11.1.1.0 0.0.0.255

network 12.1.1.0 0.0.0.255

network 13.1.1.0 0.0.0.255

#mpls lsr-id 1.1.1.1

#mpls ldp

#interface LoopBack0

ip address 1.1.1.1 255.255.255.255

#interface GigabitEthernet0/0

ip address 11.1.1.1 255.255.255.0

#interface GigabitEthernet0/1

ip address 12.1.1.1 255.255.255.0

mpls enable

mpls ldp enable

#interface GigabitEthernet0/2

ip address 13.1.1.1 255.255.255.0

mpls enable

mpls ldp enable

RT2

#sysname RT2

#ospf 1 router-id 2.2.2.2

area 0.0.0.0

network 2.2.2.2 0.0.0.0

network 12.1.1.0 0.0.0.255

network 24.1.1.0 0.0.0.255

#mpls lsr-id 2.2.2.2

#mpls ldp

#interface LoopBack0

ip address 2.2.2.2 255.255.255.255

#interface GigabitEthernet0/0

ip address 12.1.1.2 255.255.255.0

mpls enable

mpls ldp enable

#interface GigabitEthernet0/1

ip address 24.1.1.2 255.255.255.0

mpls enable

mpls ldp enable

RT3

#sysname RT3

#ospf 1 router-id 3.3.3.3

area 0.0.0.0

network 3.3.3.3 0.0.0.0

network 13.1.1.0 0.0.0.255

network 34.1.1.0 0.0.0.255

#mpls lsr-id 3.3.3.3

#mpls ldp

#interface LoopBack0

ip address 3.3.3.3 255.255.255.255

#interface GigabitEthernet0/0

ip address 13.1.1.3 255.255.255.0

mpls enable

mpls ldp enable

#interface GigabitEthernet0/1

ip address 34.1.1.3 255.255.255.0

mpls enable

mpls ldp enable

RT4

#sysname RT4

#ospf 1 router-id 4.4.4.4

area 0.0.0.0

network 4.4.4.4 0.0.0.0

network 24.1.1.0 0.0.0.255

network 34.1.1.0 0.0.0.255

network 44.1.1.0 0.0.0.255

#mpls lsr-id 4.4.4.4

#mpls ldp

#interface LoopBack0

ip address 4.4.4.4 255.255.255.255

#interface GigabitEthernet0/0

ip address 44.1.1.1 255.255.255.0

#interface GigabitEthernet0/1

ip address 24.1.1.4 255.255.255.0

mpls enable

mpls ldp enable

#interface GigabitEthernet0/2

ip address 34.1.1.4 255.255.255.0

mpls enable

mpls ldp enable

此时我们查看RT1的LDP LSP建立情况。

MPLS小实验:通过FEC标签接受控制策略配置LSP

这是命中了第3条LSP触发策略:只有32位掩码的IPv4主机路由或128位前缀的IPv6主机路由能够触发LDP建立LSP。

然后看一下PCA到PCB的当前路径。

MPLS小实验:通过FEC标签接受控制策略配置LSP

可以看到,现在是通过RT2转发的,但是MPLS中没有对应的LSP,所以不是通过MPLS转发的。接下来调整配置,把两端的私网网段引入进来。

RT1

#ip prefix-list rt1 index 10 permit 11.1.1.0 24ip prefix-list rt1 index 20 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt1

RT2

#ip prefix-list rt2 index 10 permit 11.1.1.0 24ip prefix-list rt2 index 20 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt2

RT3

#ip prefix-list rt3 index 10 permit 11.1.1.0 24ip prefix-list rt3 index 20 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt3

RT4

#ip prefix-list rt4 index 10 permit 11.1.1.0 24ip prefix-list rt4 index 20 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt4

此时我们再查看RT1的LDP LSP建立情况。

MPLS小实验:通过FEC标签接受控制策略配置LSP

可以看到仅有两个业务网段的LSP,之前的4个主机路由没有了。说明命中了第2条LSP触发策略:利用IP地址前缀列表对路由表项进行过滤,只有匹配IP地址前缀列表的路由表项才能触发建立LSP。并且该策略比第3条策略优先级要高。

再次查看PCA到PCB的转发路径,依然是经过RT2转发。

MPLS小实验:通过FEC标签接受控制策略配置LSP

在RT2和RT4的互联线路抓包,确认是经过MPLS转发的。

MPLS小实验:通过FEC标签接受控制策略配置LSP

然后在RT1上创建2条路由策略,分别是允许44.1.1.0/24和拒绝44.1.1.0/24的地址前缀列表,并将拒绝的匹配到RT2、将允许的匹配到RT3,创建标签映射的标签接受控制策略。

RT1

#ip prefix-list 12 index 10 deny 44.1.1.0 24

ip prefix-list 13 index 10 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt1

accept-label peer 2.2.2.2 prefix-list 12

accept-label peer 3.3.3.3 prefix-list 13

RT4

#ip prefix-list 24 index 10 deny 44.1.1.0 24

ip prefix-list 34 index 10 permit 44.1.1.0 24#mpls ldp

lsp-trigger prefix-list rt4

accept-label peer 2.2.2.2 prefix-list 24

accept-label peer 3.3.3.3 prefix-list 34

验证配置

按照操作提示,在配置完成之后,需要重置LDP会话,使策略生效。

MPLS小实验:通过FEC标签接受控制策略配置LSP

但是我趁着还没重置就测试了一下,发现路径已经更改过来了。

MPLS小实验:通过FEC标签接受控制策略配置LSP

再查看RT1上的LDP LSP建立情况,也只剩下通过RT3过来的一条了。

MPLS小实验:通过FEC标签接受控制策略配置LSP

然后我们在RT1上带12.1.1.1这个IP地址去测试一下看能不能访问。

MPLS小实验:通过FEC标签接受控制策略配置LSP

再使用tracert mpls ipv4命令用来查看IPv4地址前缀类型MPLS LSP从Ingress节点到Egress节点所经过的路径。

MPLS小实验:通过FEC标签接受控制策略配置LSP

果然,还是从RT3走了,不再从RT2转发了。

而且受策略的影响,RT1无法访问到2.2.2.2和3.3.3.3。

MPLS小实验:通过FEC标签接受控制策略配置LSP

查看LDP发现过程相关的详细信息。

MPLS小实验:通过FEC标签接受控制策略配置LSP

查看通过LDP学习到的FEC—标签映射信息,可以发现,去往44.1.1.0/24的下一跳只有13.1.1.3了。

MPLS小实验:通过FEC标签接受控制策略配置LSP

虽然我们没用到,但还是要知道重启LDP会话的命令。

reset mpls ldp

MPLS小实验:通过FEC标签接受控制策略配置LSP

以上就是MPLS小实验:通过FEC标签接受控制策略配置LSP的介绍。如果你还有其他问题,欢迎进行咨询探讨,希望VeCloud的专业的解决方案,可以解决你目前遇到的问题。微云网络提供全球主机托管、服务器租用、MPLS专线接入、SD-WAN组网等方面的专业服务,资源覆盖全球。欢迎咨询。

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:sales@vecloud.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

标题:MPLS小实验:通过FEC标签接受控制策略配置LSP

TAG标签:MPLSFEC

地址:http://www.kd010.com/hyzs/475.html

上一篇:SD-WAN组网管理!so wasy!
下一篇:SD-WAN组网方案助力连锁商超降本增效

Vecloud云网络解决方案

点击获取方案