MPLS基础知识汇总

发布时间:2022-07-14 16:53:16 作者:小编阅读:0

[导读]:前面简单介绍了什么是MPLS,今天针对MPLS基础深入分析知识。MPLS:交换多协议标签1、支持各种网络层协议(IPV4/6,IPX等)不注意三层使用的协议,MPLS其实算是2.5层(二层和IP多加一...

前面简单介绍了什么是MPLS,今天针对MPLS基础深入分析知识。

MPLS:交换多协议标签

1、支持各种网络层协议(IPV4/6,IPX等)不注意三层使用的协议,MPLS其实算是2.5层(二层和IP多加一个MPLS)

2、用标签交换代替传统IP数据交换

3、MPLS仅基于数据层面的技术Lable交换转发数据

一、标签交换与传统数据转发进行比较

传统数据转发:1、操作 2、最长匹配 3、递归查找

过程转发:基于数据包的转发,每个数据包都找路由

快速转发:每个流量中的第一个数据包进行路由搜索续数据基于第一个数据包的缓存转发(通过五元组确定是否为同一流量)和缓存转发

缺点:1。第一个包需要路由搜索 2.如果路由或拓扑发生变化,将无法正常转发

CEF:Cisco快速交换,将所有数据包无需查看路由表转发,直接查看Cef(FIB)自动适应路由表,无需直接转发路由表

1.标签交换转发效率优于传统数据包交换(现在不明显)

2.MPLS支持MPLS VPN 支持MPLS TE

二、MPLS模式

Frame 帧模式 Cell 信元模式

三、MPLS数据层面和控制层面

控制层面:LDP/TDP(标签分发协议) MP-BGP(BGP集团属性) Rsvp(资源预留协议)

数据层面:使用LIB(cef)优化路由表后的表,解决递归搜索

四、MPLS术语

FEC:转发等价类,具有相同转发处理方法的一类数据

LSR:标签交换路由器,标签swap(交换)撕下最后一个标签,贴上新标签,发给下一个标签LSR

E-LSR:在边界标签交换路由器中MPLS给域的边界IP域转发的流量(impose)压入标签,出MPLS域的时候要POP(弹出)标签

LSP:标签交换路径

LIB:无法转发数据的标签信息库 所有基于本路由器FEC分配的标签。本地标签分配给路由信息和其他路由器

FIB(cef):支持插入标签的转发信息库

LFIB:FIB LIB 信息库的标签转发

MPLS基础知识汇总

五、Lable

标签:20bite 范围16到220

EXP:3bite 优先级用于标签定义QOS提供服务

S:栈底位 因为可以在IP多个标签入多个标签

S=代表到达栈底 S=0未到达栈底

TTL:生存时间 8bite 用于MPLS 中防环

六、标签分发协议

1、MP-BGP

2、LDP和TDP

Lable distribution protocol 和Tag distribution protocol

TDP:cisco 私有 基于TCP或UDP封装 端口711 广播发送255.255.255.255

LDP:基于工业标准UDP或TCP 端口646 组播 224.0.0.2 (所有支持组播功能的路由器均接收)

LDP邻居发现阶段(LDP hello建邻居,UDP发送方式,进行TCP三次握手)

LDP会话建立(进行)LDP发送和发送初始化报文keeplive,并发送LDP标签分发信息)

LDP hello报文: hello 周期发送,周期时间5s,超时时间15s,包含了 LSR ID 、LSR space ID、transport address ;使用transport address 用于LDP 中TCP建立邻居关系;

七、优化机制

倒数第二次弹出:减少E-LSR如果直接弹出一个标签,如果只弹出多个外部标签

倒数第一跳向倒数第二条发送3个标签(空标签)

标签只有本地意义 异步分发

启动五个路由器 在R2 R3 R5上启用MPLS

R1 R2 R3 R4 R5启用EIGRP协议

只贴一个底层配置

interface Loopback0

ip address 4.4.4.4 255.255.255.0 配置环回口

interface Ethernet0/0

ip address 34.1.1.2 255.255.255.0 配置IP

no shutdown

interface Ethernet0/1

ip address 45.1.1.1 255.255.255.0

no shutdown

router eigrp 100 启动EIGRP

no auto-summary 关闭自动汇总

network 4.0.0.0 宣告路由

network 34.0.0.0

network 45.0.0.0

int e0/0 接口上启动MPLS

mpls ip

如果你对MPLS对技术感兴趣,欢迎与我们交流。

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:sales@vecloud.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

标题:MPLS基础知识汇总

TAG标签:MPLS

地址:http://www.kd010.com/hyzs/1091.html

上一篇:IP报头、TCP、UDP理解
下一篇:什么是MPLS

Vecloud云网络解决方案

点击获取方案