使用RSVP-TE配置MPLS TE隧道

发布时间:2022-08-05 15:43:19 作者:衡水铁头哥 铁军哥阅读:0

[导读]:RSVP是一种用来在网络上请求预留资源的信令协议,扩展以后可以作为MPLS TE的标签分发协议,在沿着指定路径分发MPLS标签的同时携带资源预留信息,以建立CRLSP,不需要为每台设备单独进行配置。支...

RSVP是一种用来在网络上请求预留资源的信令协议,扩展以后可以作为MPLS TE的标签分发协议,在沿着指定路径分发MPLS标签的同时携带资源预留信息,以建立CRLSP,不需要为每台设备单独进行配置。支持MPLS标签分发的RSVP也称为RSVP-TE。

在配置静态CRLSP时,我们首先要确定静态CRLSP的Ingress节点、Transit节点和Egress节点,并且要保证相邻两个LSR(Label Switching Router,标签交换路由器)之间,上游LSR的出标签值和下游LSR的入标签值必须相同。以上个实验中的配置为例,VSR1配置的是:

static-cr-lsp ingress 13 nexthop 12.1.1.2 out-label 120 bandwidth ct0 20000

VSR2配置的是:

static-cr-lsp transit 13 in-label 120 nexthop 23.1.1.3 out-label 230 bandwidth ct0 20000

VSR3配置的是:

static-cr-lsp egress 13 in-label 230

可以看到,上游LSR的出标签值和下游LSR的入标签值完全相同,并且在Ingress节点和Transit节点都配置了预留带宽,从上次结果来看,这个带宽值说是资源预留,其实就是限速了。

那使用RSVP-TE该怎么配置呢?我们今天来配置一下。

组网需求

RT1-3均支持MPLS,通过IS-IS进行互通。在RT1到RT3之间使用RSVP-TE建立一条MPLS TE隧道,使11.1.1.0/24和33.1.1.0/24这两个网段中互访的报文能够通过MPLS进行传输,并且配置隧道最大带宽为20000kbps,隧道沿途链路的最大带宽为80000kbps,最大预留保证带宽为40000kbps。

组网图

RSVP-TE配置组网图

使用RSVP-TE配置MPLS TE隧道

实验环境

VMWare ESXi 6.7.0(ProLiant DL360 Gen9,48核心,128 GB内存)

H3C VSR1000(Version 7.1.064, Release 0621P18,4核心,4 GB内存)

CentOS Linux 7.9.2009(测试用虚拟机,8核心,16 GB内存)

基础网络配置

基础配置仍以上次的配置为基础(使用静态CRLSP配置MPLS TE隧道),按照组网图所示配置各接口的IP地址和掩码,设备间配置IS-IS协议发布接口所在网段的路由,包括Loopback接口。

VSR1

#

isis 1

 is-level level-1

 network-entity 10.0000.0000.0001.00

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

 isis enable 1

#

interface GigabitEthernet2/0

 ip address 11.1.1.1 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/0

 ip address 12.1.1.1 255.255.255.0

 isis enable 1

VSR2

#

isis 1

 is-level level-1

 network-entity 10.0000.0000.0002.00

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

 isis enable 1

#

interface GigabitEthernet2/0

 ip address 12.1.1.2 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/0

 ip address 23.1.1.2 255.255.255.0

 isis enable 1

VSR3

#

isis 1

 is-level level-1

 network-entity 10.0000.0000.0003.00

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

 isis enable 1

#

interface GigabitEthernet2/0

 ip address 23.1.1.3 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/0

 ip address 33.1.1.3 255.255.255.0

 isis enable 1

RSVP-TE配置

接下来配置RSVP-TE。

VSR1

配置LSR ID,开启设备的MPLS能力、MPLS TE能力和RSVP能力。

#

mpls lsr-id 1.1.1.1

#

mpls te

#

rsvp

#

interface GigabitEthernet3/0

 mpls enable

 mpls te enable

 rsvp enable

配置IS-IS TE时,和我们前面配置SRv6时类似(SRv6典型配置),将IS-IS的开销值类型配置为wide。

#

isis 1

 cost-style wide

 mpls te enable

配置TE链路的最大带宽和最大可预留带宽。

#

interface GigabitEthernet3/0

 mpls te max-link-bandwidth 80000

 mpls te max-reservable-bandwidth 40000

配置MPLS TE隧道Tunnel13,隧道的目的地址为VSR3的LSR ID(3.3.3.3),采用RSVP-TE信令协议建立建立MPLS TE隧道(默认配置)。并配置隧道所需的带宽为20000kbps。

#

interface Tunnel13 mode mpls-te

 ip address 13.1.1.1 255.255.255.0

 mpls te signaling rsvp-te

 mpls te bandwidth ct0 20000

 destination 3.3.3.3

配置静态路由,使得到达网络33.1.1.0/24的流量通过MPLS TE隧道接口Tunnel13转发。

#

ip route-static 33.1.1.0 24 Tunnel13 preference 5

VSR2

VSR2、VSR3的配置和VSR1相比,缺少了MPLS TE隧道和静态路由的配置,其他一致,配置如下:

#

mpls lsr-id 2.2.2.2

#

mpls te

#

rsvp

#

interface GigabitEthernet2/0

 mpls enable

 mpls te enable

 rsvp enable

 mpls te max-link-bandwidth 80000

 mpls te max-reservable-bandwidth 40000

#

interface GigabitEthernet3/0

 mpls enable

 mpls te enable

 rsvp enable

 mpls te max-link-bandwidth 80000

 mpls te max-reservable-bandwidth 40000

#

isis 1

 cost-style wide

 mpls te enable

VSR3

#

mpls lsr-id 3.3.3.3

#

mpls te

#

rsvp

#

interface GigabitEthernet2/0

 mpls enable

 mpls te enable

 rsvp enable

 mpls te max-link-bandwidth 80000

 mpls te max-reservable-bandwidth 40000

#

isis 1

 cost-style wide

 mpls te enable

验证配置

此时我们可以看到,VSR1上去往PCB的路由是手工配置的,优先级是5,下一跳为MPLS TE隧道接口Tunnel13。

使用RSVP-TE配置MPLS TE隧道

然后测试从PCA到PCB的带宽情况。

使用RSVP-TE配置MPLS TE隧道

测得带宽为19.9 Mbps,与配置的20000kbps大体相符。

然后我们再测试一下从PCB到PCA的反向带宽情况。

使用RSVP-TE配置MPLS TE隧道

测得带宽为5.97 Gbps,说明PCB访问PCA的流量没有经过隧道转发,和在路由表中看到的情况一致。

使用RSVP-TE配置MPLS TE隧道

使用display interface tunnel命令,查看Tunnel接口的状态。

使用RSVP-TE配置MPLS TE隧道

可以看到,隧道的接口状态为UP,协议为CR_LSP。

使用display mpls te tunnel-interface命令,查看MPLS TE隧道的建立情况。

使用RSVP-TE配置MPLS TE隧道

在这里,我们依旧可以看到隧道的Ingress LSR和Egress LSR信息,信令协议为RSVP-TE,而且服务类型为配置的CT0,隧道带宽则为指定的20000 kbps。

在VSR1上执行display mpls lsp verbose命令,查看LSP的建立情况。

使用RSVP-TE配置MPLS TE隧道

如果要双向限速,就要在VSR上也配置一下MPLS TE隧道和静态路由,我们把带宽配置为30000 kbps。

#

interface Tunnel31 mode mpls-te

 ip address 31.1.1.1 255.255.255.0

 mpls te bandwidth ct0 30000

 destination 1.1.1.1

#

ip route-static 11.1.1.0 24 Tunnel31 preference 5

最后再测试从PCB到PCA的带宽情况。

使用RSVP-TE配置MPLS TE隧道

测得带宽为29.6 Mbps,与配置的30000kbps大体相符,这限速限的稳稳当当!

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:sales@vecloud.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

标题:使用RSVP-TE配置MPLS TE隧道

TAG标签:MPLS

地址:http://www.kd010.com/hyzs/1222.html

上一篇:智能化SD-WAN赋能,步长制药智慧升级的数字“配方”
下一篇:永辉门店数字化升级,握紧了SD-WAN这把金钥匙

Vecloud云网络解决方案

点击获取方案